This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again, but selecting Disallow Cookies will mean you are unable to log into the forum and functionality will be resticted when viewing the forum as a guest. Clearing your Browser Cookies will allow you to reset your cookies choice for this forum

By clicking this Link you help to Support this Forum when you buy any items from AMAZON
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Flash Netgear XR500 Firmware onto the Netgear R7800
#1
Wink 
For those Flash hackers out there,  Xvortex has produced a firmware from the Netgear XR500 to Flash onto the Netgear R7800 [Image: wink.gif] 

Both routers have nearly identical hardware and the XR500 has a higher value of Flash (256Mb), same RAM, CPU and Wifi chipsets and seems to be working a treat.


I got hold of the following file from a well known coder 'Xvortex' - 'R7800-V2.2.1.10.img' and tried the usual thing with tftp2.exe and could not get the tool to flash the firmware to the router.

I did the normal, got router into recovery mode by depressing reset button, power on router and wait until flashing Orange Light Started to flash White.

Connected Ethernet cable from laptop to Router and made sure Ethernet Connection had Static IP address assigned to it of 192.168.1.2 , but still not luck.

I disabled Firewall and all that normal stuff, but still no joy.

So I decided to go back to basics and flash from CMD line with my Windows 10 Dell Laptop

On my laptop, I navigated to Control Panel > Programs and Features, click on Turn Windows features on. The I selected TFTP Client from the check list. Click ok then.

I then opened a command prompt window. hit enter. at the command prompt write "cd desktop" (remove quotes). Finally, type "tftp -i 192.168.1.1 put firmware-file-name" (remove quotes) and hit enter. I then waited several minutes and router should reboot itself if all goes well.

Actual Command I used was tftp -i 192.168.1.1 put R7800-V2.2.1.10.img and make sure file is located on your desktop

Unsure if Netgear XR7800 ( [Image: biggrin.gif] ) can be updated with newer Stock Firmware for the XR500, so if any body else gets a chance, let us know as I am still getting my head around DumaOS and Geo-Filters etc?


   

UK Sentinel

Note: if you brick or damage your router after reading this thread and following my guidance, we can help to try to fix, but it is your choice and WhatsYorRouter.com is not responsible.


Attached Files
.img   R7800-V2.2.1.10.img (Size: 28.49 MB / Downloads: 2)
UK Sentinel


DrayTeK 130 Modem connected to Netgear XR500, ASUS RT-AC86U then connected to Netgear XR500 

Reply



Forum Jump:


Users browsing this thread:
1 Guest(s)

This Forum was originally created to provide a means to allow users of ASUS (SOHO) Routers - both Wireless and xDSL (modem) based to freely communicate within a Community type forum where members can work together towards sharing experience, knowledge and ideas, I have recently also been asked to include Netgear and AVM wifi / modem based routers for discussion. All I ask is that we are all fair and reasonable, we try to add value where we can and not use this forum for other non community agendas and lastly, please feel free to dop me a message offline if you feel in anyways I can improve upon this site etc.
By clicking this Link you help to Support this Forum when you buy any items from AMAZON

Forum software by © MyBB Theme © iAndrew 2016